We're sorry GroupDocsApp doesn't work properply without JavaScript enabled.

Free Support Forum - groupdocs.app

Some of the tools do not leave comments in docx

Text field, watermark, arrow, and distance tools are not leaving comments in Docx files.

I figure out that some of them are not leaving comments just in black spaces, for example, arrow, distance, and text tools, but the watermark is not leaving comments never. I can see the comment in the web application, but not in the downloaded annotated file.

I had this problem on version 19.4, so I updated it to 19.7, as the bug is still in this version I’m updating my application to the newer version 21.7, but in the meantime, I made a test on the live demo application and I saw the bug is still happening.

Link of my test in Live Demo:

@john.mcqueide

We tried to reproduce this issue using arrow tool. But the downloaded file has the comments that were added in the web app. Have a look at this screenshot.png (37.9 KB).

Hello @Atir_Tahir, thanks for your attention.

And about the other tools? Distance, watermark, text field tools.

Did you see the document that I used as an example?

Sorry, I received a message that my post was hidden by community flag.

I am not fluent in English, so if I have said something bad excuse me. I didn’t want to be rude.

@john.mcqueide

Please share the problematic file and we’ll look into this scenario.
All annotations are working without any exception. However, in case of Watermark annotation, the comment is not visible in the download/output PDF. We are investigating this issue with ticket ID ANNOTATIONAPP-85. You’ll be notified in case of any update.

@Atir_Tahir

Follow a Google Drive folder with the original file (“bug 7685.docx”) and the annotated file (“bug 7685 (4).docx”). I added comments to all annotations, but they just worked with the distance tool.

Hello @Atir_Tahir,

Were you able to access the files and reproduce the issue?

@john.mcqueide

This issue is reproduced at our end. However, we’ve logged it in our internal issue tracking system with ID ANNOTATIONAPP-86.
You’ll be notified in case of any progress update.

@Atir_Tahir

When the ticket has an ID ANNOTATIONAPP-XX the problem is in the Angular Project and ANNOTATIONJAVA-XX is Java Project?

I asking this because I made a test with Spring Demo Project and Java Sample Project and in both projects I saw that text field and watermark don’t leave comment in PDF document.

@john.mcqueide

If the issue in our free web app, we log it as ANNOTATIONAPP-XX. However, if the issue is with our on-premises API, it is logged as ANNOTATIONJAVA-XX.

That’s is a back-end/on-premises API issue. Please always raise such issues on this forum.

@john.mcqueide

ANNOTATIONAPP-85 is now resolved. Please try the web app again.

I check the repository and I haven’t seen any update on branch master.

These are the results I got running some examples:

Example AddResourcesRedactionAnnotation - the reply comments don’t appear, just the message.
Examples AddTextStrikeoutAnnotation, AddTextUnderlineAnnotation, AddTextHighlightAnnotation - I could see just the first comment, I couldn’t see the second comment.
Example AddTextFieldAnnotation - Neither message nor reply comment appeared

Repository: https://github.com/groupdocs-annotation/GroupDocs.Annotation-for-Java
Git Revision: 72a3efe9

@john.mcqueide

We’re further looking into this issue. You’ll be notified about the outcomes.

1 Like

Hello, any update about this issue? Can someone give an ETA for it?