We're sorry GroupDocsApp doesn't work properply without JavaScript enabled.

Free Support Forum - groupdocs.app

Online MSG Metadata Editor

Hi there, I tried using the online MSG metadata editor. The MSG file uploads successfully however I cannot edit the metadata fields as mentioned. I can only highlight them?
Screenshot attached below for your info.

image.png (17.7 KB)


We are investigating this issue. Your investiation ticket ID is METADATAAPP-61. We’ll notify you in case of any update.

Many thanks Atir.

1 Like


You’re welcome.


We’ve an update on METADATAAPP61. Currently, MSG format is read-only. Why? Because the fields you see here.PNG (71.9 KB), if modified, could affect email functionality. Subject, sender, recipients and other such fields displayed by the Metadata App are basically part of the email content and must stay as they are.
However, could you please explicitly specify the meta-data fields that you want to update/edit and we’ll look into the possibility.
Meanwhile, please have a look at Aspose.Email web app that provides more ways to edit email.

Hi Atir,
Thanks for the clarification. Am looking to change the recipients field only.
I have used Aspose.Email web app and made the changes I require - however it does not change the recipient field.


Content such as subject, sender, recipients and other fields displayed by Metadata App are actually part of the email content. They bear important information that is necessary to deliver the email or help the recipient to interpret it. According to the definition, metadata is just “data about data”. So, that is why this field is read-only.

Upon your request, we’ve implemented the ability to edit recipients of MSG emails. Please try the current version of Metadata App

Heyho! Thank you for great tool, but it does not work for me today. Once I upload msg file to online editor it redirects me to a page saying “http version is not supported”. Tried all browsers, same. It did work a few weeks ago. @Atir_Tahir @sergey.voloshin

“The page cannot be displayed because the HTTP version is not supported.”

Same error for me today.

@Against @Missmashing

We are investigating this issue with ticket ID METADATAAPP-108.

This issue is fixed. Please try the web app again.